CREATING TABLES WITH Beyond 20/20™
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INTRODUCTION

The BEyonD 20/20™ BROWSER enables you to quickly tabulate data to create your own custom tables. You can create
a table by opening an extract and choosing up to 8 variables to work with at a time, and manipulating two or more of
them in a single table layout. The buttons displayed above serve as a legend and are referred to within this document.

CREATING YOUR OWN TABLES

Opening an Extract

To locate and open an BEyoND 20/20™ Extract:

1) Choose the Open command from the File menu or click on the File Open button.

2) Set the List Files of Type box to Extract Files (*.ivx)

3) Select the extract you want and click on OK.

As soon as you've opened an extract, the BRowsER displays an empty table view and the source field tiles to the right.

Viewing the Microdata

1) You canview source field notes by selecting a source field and choosing Source Field Summary from the Data
menu.

2) Double click on the tile to see the categories or the range associated with the field, depending on whether it is
character or numeric. The categories are those defined by the database, and the bands shown are those defined
automatically by BEyoND 20/20™ (see Define Recode and Define Bands, below).

3) Extract notes can be viewed by choosing Extract Summary from the Data menu.

Positioning Tiles for Dimensions

Note: At least two dimensions must be defined before the data can be loaded (see Generating the Table). To select tiles

for dimensions:

1) To locate a source field tile quickly, choose the Find Source Field command from the Data menu. Highlight the
topics you want to browse. Then highlight the source field you want to use (one at a time).

2) Click on OK, and that source field tile will be located.

At this point, it is necessary to apply any modifications to the field, if desired, using the functions Define Recode,
Define Bands, Define Derived Fields, or Record Constraints, below.

3) Drag the tile into the row dimension area at the left side of the table. When that area is highlighted, release the left
mouse button.

4) Locate and drag a second source field tile into the column dimension at the top of the table.

5) Drag and drop up to six more source field tiles into the Dimension bar, which is the area above the column headings.

6) Character fields have both codes and labels. To switch between codes and labels, select the desired row or column
and click the Change Labels button.

Define Recode

This option lets you create an new source field which combines categories (items) of an original character source field:
1) Locate and select the source field tile you want to modify and choose Define Recode from the Data menu.

2) |If desired, enter a different New Source Field Name from the one suggested.

BEYOND 20/20™ [nstruction Sheet - Creating Tables With BEvonD 20/20™



3)

4)

5)

Type in the new code title and then highlight the codes you wish to include within that new code. Select them or
deselect them using the Add and Remove buttons. The new code is automatically saved when you begin to type
another new code title.

Select and enter the remaining Available Codes using the Use As Is feature in the Members area. This step must be

completed in order to activate the OK button.
Click on OK. The new source field tile is created (scroll to find it). Double-click on your new source field tile in order

to view the changes you have made within the .ivd file.

Define Bands
This option lets you create a new source field by changing the bands of an original numeric source field:

1)
2)
3)
4)
5)

Locate and select the source field tile you want to modify and choose Define Bands from the Data menu.

If desired, enter a different New Source Field Name from the one suggested.

Under Initialize, enter a value for Start and a value for Increment.

Click on Apply in order to see the new bands. Scroll through the new bands to see the result.

Click on OK. You will receive a prompt saying, ‘You are about to create a new field. Do you want to continue?’.
Simply press OK. Scroll down to view your new field.

Define Derived Fields
This option lets you create a new source field by applying mathematical operations to one or more existing source field
tiles.

1)
2)
3)
4)
5)

Click on Define Derived Field under the Data menu.

One at a time, click on the Available fields that you want to use and press Insert to enter them in the formula.
Enter any mathematical operation in the Formula area so that it contains the formula you wish.

Enter the New Source Field Name you would like to use.

Click on OK.

Set Record Constraints
This option lets you create a table subject to a constraint on a field:

1)
2)
3)
4)

5)

6)

8)

Choose Record Constraints from the Data menu.

Drag and drop the source field tile for which you would like a constraint.

Double-click on the text in the Criteria row. The Numeric Constraint (numeric field) or the Constraint field (character
field) dialog box appears.

In the Numeric Constraint dialog box, select a range or comparison in the Type of Constraint area. In your select
Range, enter the minimum and maximum values to be included in the constraint. If you select Comparison in the
Value box, enter the value you want to use as the constraint.

In the Constraint Field dialog box, select one or more codes by positioning the mouse pointer over the appropriate
code and clicking on the left mouse button. To select more than one adjacent code, click on and hold the left mouse
button and drag the mouse until the codes you want are selected. To select non-adjacent codes, press the CTRL
key, and click on the left mouse button.

Click on OK.

Repeats Steps 2-5 for each source field you want to impose constraints on. As you drag and drop the tiles, a single
vertical line separates the columns that are filled. This indicates that the Browser will search for records that match
all the constraints in each of the columns, indicating an “And” condition. Clicking on the Or button inserts a
separation line to the right of the selected column. This indicates that the Browser will find all records that match all
the constraints in either column, indicating an “Or” condition.

To limit the source field data that will be loaded into a table, click on OK. If you want to create a new extract
containing a subset of the records according to the specified constraints, click on Subset. Save this extract and
enter a new name. This new extract is independent of the original extract.

Applying a Weighting Factor to the Data

1)

2)
3)

Choose Set Weight Field from the Data menu. All the numeric source fields, including the weight fields, are now
listed. The different weights are listed first with a _ before the weight name.

Select the field you want to use as a weighting factor.

Click on OK.
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Filling a table with Numeric Source Field Values

You can fill a table with values that are sums or averages of numeric source fields instead of counts:

1) Drag and drop the source field tile that you want values for into the cell area of the table view. The source
field’s type must be numeric. The BROWSER presents the Edit Unit Item dialog box.

2) The Calculated As area contains the statistical values you can use. Select the one you want to apply.

3) The Item Name shows the statistical method you have chosen followed by the name of the source field.
Unless you change the Item name, it will be used for the new source field. Change the name if you wish.

4) Click on OK. An asterisk appears on the source field tile to indicate that the BROWSER has created a new item
in the “Units” dimension.

Generating the Table

Once the table has been defined, the next step is to load the data. Simply click on the Go button or select Go
from the Data menu. At this point you may continue to work with your table or save it for later use (see the next
set of instructions, including Saving a Table).
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WORKING WITH Beyond 20/20™ TABLES
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WORKING WITH BROWSER TABLES

The following instructions are based on the Bevonp 20/20™ Browser Quickstart Guide.

Opening a Table

1) To open a table, click on the Find table button or choose Find from the File menu. A Find window appears.
2) Specify the location of the table in the directory section. A list of tables will be displayed.

3) Select a table and choose OK.

Table Browsing with 3 or more dimensions

1) You can browse through the items in any dimension. Select the Active Dimension by clicking on your choice of dimension in
the Dimension bar (the area above the column headings). The dimension is how shown in the Active Dimension box located
in the toolbar.

2) Click on the Previous Item button or the Next Item button to browse through the items in that dimension. Note that the active
dimension tile shows the code or label of the item whose data is currently displayed.

Switching Table Dimensions
You can switch the column and row dimensions of a table by clicking and dragging the row or column and dropping it on the other.

Nesting Table Dimensions

With the left mouse button depressed, slowly drag the desired dimension tile (one that is not already occupying a row or column)
from the Dimension bar to the top or bottom edge of the column labels, or to the right or left edge of the row labels, until a thick line
(or highlight) appears. Release the mouse button, and the dragged dimension will be nested.

Selecting Data from a Table

You can perform the following operations by first selecting data: display only the selected data by choosing Show from the Item
menu; hide the selected data from your current view by choosing Hide from the Item menu (to display the hidden data choose
Show all from the Dimension menu); chart the data; or copy your selection to the clipboard and move it to another application.
1) To select a row or column of data, click on the corresponding row or column heading.

2) To select adjacent rows or columns, drag the mouse across the row or column headings.

3) To select non-adjacent rows and/or columns, press the CTRL key while you click on the row or column headings.

All of these operations can also be accessed by clicking on the right mouse button to display the shortcut menu.

Charting Data

1) Select the rows and/or columns that you want to chart.

2) Click on the Display Chart button in the Tool bar.

3) To change the current chart type, choose the Chart Options command from the View menu, or with the mouse pointer in the
chart view, click on the right mouse button to see the Charting shortcut menu.

4) Make a selection and click on OK to return to the chart view.

Chart Browsing

The ChartBrowsing™ feature lets you create a series of charts in rapid succession. With the mouse pointer in the chart view, click
on one of the headings in the title of the chart to make that dimension active. Use the Previous Item and Next Item buttons to
chart the previous or next item.

Printing a Table or Chart
To print a table or chart view, select Print from the File menu or click on the Print button.
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Saving a Table

To save the table:

1) Choose Save As from the File menu.

2) Specify the directory and file name you want to save it under. Click on OK.

3) The BROWSER prompts you to enter summary information. Enter the Table Title and Category which will be displayed in the
Find dialog box. If you wish, enter Keywords and Table Notes to help you find the table later.

4) Click on OK.

You can save Beyonp 20/20™ table data in several other formats including Database files (*.dbf) and Worksheet files (*.wks). When
saving to any non-Bevonp 20/20™ format, you'll need to nest all the dimensions along the rows or columns before you save, if you
want to retain the data for all dimensions (see Nesting Table Dimensions).
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